SSL issues due to revoked local certificate for localhost.localstack.cloud
Incident Report for LocalStack
Resolved
We have implemented changes that should resolve the issue with the revoked certificate. These changes are incorporated in LocalStack version 3.7.0.

To update your LocalStack container image to the latest version, or specifically to version 3.7.0, you can pull the latest image by using the following command:
```
docker pull localstack/localstack-pro:latest
```

Or, if you prefer to use a tagged version:
```
docker pull localstack/localstack-pro:3.7.0
```

Should you have any more questions or require further assistance, please do not hesitate to contact us on Slack or via support email.
Posted Aug 29, 2024 - 12:57 UTC
Monitoring
We have resolved the issue and the certificates should be valid and active now for the latest community image (localstack/localstack:latest). The fix for the Pro image (localstack/localstack-pro) would be available latest by tomorrow (August 29th).

We apologize again for any inconvenience, and thank you for your patience. We've put measures in place to prevent this type of issue from happening again in the future.
Posted Aug 28, 2024 - 19:16 UTC
Identified
We are currently investigating an incident regarding the revocation of our `localhost.localstack.cloud` certificate used in the LocalStack container. A revoked certificate may cause certain browsers and tools to distrust it, which can cause issues with HTTPS/TLS communication with the LocalStack APIs. Consequently, this could lead to errors when using the LocalStack Web Application, Desktop Application, or any other tools that rely on an HTTPS connection.

As a temporary workaround, we recommend using HTTP connections when accessing LocalStack. We will keep you informed and provide an update as soon as the issue is resolved. Thank you for your understanding and patience.
Posted Aug 28, 2024 - 08:47 UTC